rider mac

1.安装Rider(很明显)

2.安装Resharper - unity插件(不太明显:你不用Resharper,而且文档建议你不需要它)。但是你做的事情。NB:这是安装程序的“自动建议”——安装程序很棒)

3.配置Unity以使用Rider

4.配置Rider以使用Unity

5.安装Rider插件

安装插件到你的项目中

从相同的官方页面——除了他们的指示有点错误(他们起作用,但是过度了)。

每个项目都需要这样做。

复制文件夹资产/插件/编辑/ JetBrains从这个仓库资产/插件/编辑/ JetBrains在您的项目。…注意:您不需要复制有关文件(目前:两个.cs文件)到“Assets/Plugins/Editor/JetBrains”。如果您遵循您在项目中使用的任何标准,那么代码运行良好。唯一的要求是parent/grandparent/etc文件夹被命名为“编辑器”(这是一个Unity特性)。

拿我的文件夹位置和命名来举例:Assets/Plugins/3rd-party/RiderEAP/Editor/

配置Rider以使用Unity

首先:

退出Rider,并通过Unity重新开始

通过在Unity编辑器中找到你的脚本并双击它们来实现这一点。如果您已经正确地完成了上述步骤,将打开一个新的Rider副本,并将自动打开脚本。

如果你不这样做,Rider会尝试让你创建一个新的项目,这是一个痛苦和痛苦的道路,你想要避免(你想要Unity管理项目,而不是Rider)。

没有什么作用;修复bug

如果您稍等,并查看屏幕底部的状态栏,您将看到出现一个错误。点击状态栏了解更多信息(这是标准的JetBrains IDE行为)。你会看到这个错误:

解决“我在这里的游戏”负载失败

Rider无法在这台机器上发现Mono运行时。

不要在错误信息中点击链接!错误出现是因为OS X不包括Mono,也不包括Rider。但这就是你的“Unity 5.5 +”派上用场的地方。Courtest这个Riderbug报告,我们知道我们可以使用Mono的副本在Unity 5.5,以及如何。

打开Rider的偏好(cmd -,作为OS X的正常值):

 

2017年6月更新:Jetbrains已经对Rider做出了改变,这个设置已经不存在了。如果旧的方法对你有效,你现在必须重新使用下面的设置:

 

…感谢Ilya计算出来,从JetBrains Kirill告诉我们新的setting-name。

…点击右边的按钮来浏览,并导航到文件夹:“/应用程序/UnityUnity。应用/内容/ MonoBleedingEdge”(注:如果你安装了不同版本的Unity,你要导航到/应用程序/Unity- 5.5,或.6,相反——无论你安装5.5 +版本)。

看一下状态栏——你应该看到左边的面板自动更新看起来就像在MonoDevelop中一样

希望可以帮助到你,更多的unity相关内容,就在纳金论坛上去查看。

let us的反意疑问句 火狐娱乐代理 visual c 2008 x64 tp link刷第三方固件 住校自缚的初一女孩 livecd修复grub 安卓手机怎么解锁密码 azusttack 4资源 cocked d85720d 00.kdz 三头中特王 youreFiNe as sb hoped 1493年 西方 sketches pro mac hand on ability indesign怎么导出单页 王杰希x叶修纯肉 bbc news radio online how to use airdrop l rest l rust 佛说水深不语人稳不言 help wait mywife 三岛 凛 ios launchimage non inferiority test boni mwaitege song 男主是杀人犯的小说 sexual object すべてがfになる

Copyright 资料库 Some Rights Reserved

如反馈或投诉等情况联系:une35498#163.com